Stitch X Purchase Orders and Transfer Orders Failing
Incident Report for Stitch Labs
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 30, 2019 - 08:47 PST
Monitoring
A fix has been implemented and we are monitoring the results
Posted 4 months ago. Jan 30, 2019 - 08:25 PST
Identified
The issue has been identified and we are working to implement the fix now
Posted 4 months ago. Jan 30, 2019 - 08:13 PST
Investigating
Our engineers are working to resolve an issue affecting POs and TOs on Stitch X accounts.
Posted 4 months ago. Jan 30, 2019 - 08:03 PST
This incident affected: Application.