Stitch X Purchase Orders and Transfer Orders Failing
Incident Report for Stitch Labs
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 28, 2019 - 14:01 PST
Monitoring
A fix has been implemented and we are monitoring any lingering effects of the issue.
Posted 4 months ago. Jan 28, 2019 - 11:41 PST
Identified
We're implementing a fix now and you should start to see POs and TOs process shortly.
Posted 4 months ago. Jan 28, 2019 - 11:27 PST
Investigating
Our engineers are working to resolve an issue affecting POs and TOs on Stitch X accounts.
Posted 4 months ago. Jan 28, 2019 - 10:54 PST
This incident affected: Application.