Impaired Service
Incident Report for Stitch Labs
Resolved
Thanks for your patience!
Posted 4 months ago. Apr 21, 2017 - 08:02 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Apr 20, 2017 - 11:18 PDT
Identified
We have identified an issue affecting some accounts from accessing line items on invoices.
Posted 4 months ago. Apr 19, 2017 - 17:55 PDT